Remove Commas from Number data types in Resultset

Note: please leave bug reports and feature requests on

Remove Commas from Number data types in Resultset

Postby dan.wieder » Wed Sep 16, 2015 3:51 pm

Hello,

I have tried to remove the by going to preferences>data formats> selecting Numbers as Type> uncheck 'Use Grouping' feature>Click Apply. Every time i follow this process it reverts to the default settings which is still giving me a commas for columns that have a number as the data type.

Thoughts?
dan.wieder
 
Posts: 1
Joined: Wed Sep 16, 2015 3:49 pm

Re: Remove Commas from Number data types in Resultset

Postby Serge » Wed Sep 16, 2015 10:34 pm

There is a bug in global data format configuration.
Try to reopen SQL editor. Or to change datasource-specific data format (in bottom right corner of results grid click on Configure button, then choose Preferences).
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: Remove Commas from Number data types in Resultset

Postby prabhath » Wed Oct 14, 2015 8:38 pm

Serge, still doesn't work. Either in the global preferences OR the datasource-specific preferences... Any setting change you make in the Data Format section doesn't apply. This is true as of v3.5.1
prabhath
 
Posts: 2
Joined: Wed Oct 14, 2015 8:35 pm

Re: Remove Commas from Number data types in Resultset

Postby prabhath » Wed Oct 14, 2015 8:42 pm

Scratch that, it looks like if I make a setting change to one of the settings under the Numbers section, such as, "Maximum Fraction Digits".. the setting is taken only if I make the change and then click somewhere off the cell. Then I click apply and my setting change works.

However, this still doesn't work for the "use grouping" checkbox - this would be really helpful to fix as any sort of export is completely broken (i.e. exporting to a CSV with a number format that has commas isn't fun :)
prabhath
 
Posts: 2
Joined: Wed Oct 14, 2015 8:35 pm

Re: Remove Commas from Number data types in Resultset

Postby Serge » Wed Oct 14, 2015 9:37 pm

Can't reproduce that.

What OS do you have?
Is that problem appears only during data export or in results panel visualization too?
Did you try to reopen table/SQL editor? (data formatting settings is cached for active query).
Does data formatting config actually changes (i.e. if you disable grouping, press ok, then open preferences again - is grouping still disabled)?

Thanks
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: Remove Commas from Number data types in Resultset

Postby kcaran » Fri Oct 23, 2015 7:36 pm

I have the same issue on MacOS with both versions 3.0.2 and 3.5.1.

I click on the 'Use Grouping' checkbox for focus, and then uncheck it. As soon as I focus on a different field (say, Maximum integer digits), the checkbox re-checks itself! I don't think the application is every seeing the preference change. The rest of the settings seem to change OK.

I love DBeaver!
kcaran
 
Posts: 2
Joined: Fri Oct 23, 2015 7:22 pm

Re: Remove Commas from Number data types in Resultset

Postby Serge » Sat Oct 24, 2015 3:00 pm

I'll fix (and redesign) boolean properties editor in the next version. It should solve these problems on MacOS.
Version 3.5.2 will be released on the next week.

PS https://github.com/serge-rider/dbeaver/issues/18
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: Remove Commas from Number data types in Resultset

Postby Serge » Tue Oct 27, 2015 12:06 pm

Try version 3.5.2
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: Remove Commas from Number data types in Resultset

Postby kcaran » Tue Feb 09, 2016 5:35 pm

I'm sorry I'm so late posting, but the new version works great. Thanks!
kcaran
 
Posts: 2
Joined: Fri Oct 23, 2015 7:22 pm


Return to Support



Who is online

Users browsing this forum: No registered users and 2 guests