Bug with limit modifier

Note: please leave bug reports and feature requests on

Bug with limit modifier

Postby rrsolver » Mon Aug 10, 2015 8:46 pm

Last edited by rrsolver on Wed Aug 12, 2015 5:05 pm, edited 1 time in total.
rrsolver
 
Posts: 40
Joined: Thu Nov 06, 2014 5:20 pm

Re: Bug with limit modifier

Postby Serge » Wed Aug 12, 2015 11:06 am

That's quite strange. Because execution log shows exactly the same query that DBeaver tries to execute.
And I can't reproduce this issue because I don't have an access to a live Vertica server.

DBeaver uses LIMIT modifier in all SELECT statements which do not have LIMIT inside. In some cases it can lead to errors.
You can disable implicit LIMITs: turn off checkbox in Preferences->Common->Result Sets->Queries->"Use SQL to limit fetch size".
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: Bug with limit modifier

Postby rrsolver » Thu Aug 13, 2015 4:44 pm

I've attached screenshots showing the behavior.

Is there something I'm missing / any other way for me to get more information

error.png
error.png (93.39 KiB) Viewed 19030 times
rrsolver
 
Posts: 40
Joined: Thu Nov 06, 2014 5:20 pm

Re: Bug with limit modifier

Postby fjmorenog » Fri Apr 08, 2016 1:26 pm

I was having the same problem, updated to the version 3.6.3 and now is working OK
fjmorenog
 
Posts: 1
Joined: Fri Apr 08, 2016 1:17 am


Return to Support



Who is online

Users browsing this forum: Google [Bot] and 15 guests