Error on Data Transfer

Note: please leave bug reports and feature requests on

Error on Data Transfer

Postby joselitux » Sat Apr 06, 2013 11:53 am

Hi all

Testing the newly added Data Transfer feature. Tried to transfer a table from remote server to local machine where DBeaver is installed. Created a local database named TESTING and tried that DBeaver managed the create destination table.
Get an error:

Can't alter target schema:
CREATE TABLE TESTING.mytable_local(
id int NOT NULL,
Name varchar(64) NOT NULL,
Attribute varchar(32) NOT NULL,
Value varchar(253) NOT NULL,
mime varchar(200),
PRIMARY KEY (id)
)

thanks
joselitux
 
Posts: 43
Joined: Thu Oct 25, 2012 12:11 pm

Re: Error on Data Transfer

Postby Serge » Mon Apr 08, 2013 4:04 pm

Hi,

When you transfer data to a new table DBeaver provides just very basic functionality here.
Usually most complicated part is a data type mappings. Each database engine has it's own set of data types and a huge set of possible type modifiers. Also usually it is not possible to use keyword as column name and I believe that "name", "value" may be a keyword in some database.
You may set any custom target column names and data types when configure data transfer.

I'll post a few configuration screenshots later today.
BTW What is your source and what is your target database?
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: Error on Data Transfer

Postby joselitux » Tue Apr 09, 2013 9:38 am

Worked at second try. Dunno why

Origin Database and Target Database schemas are identical
joselitux
 
Posts: 43
Joined: Thu Oct 25, 2012 12:11 pm


Return to Support



Who is online

Users browsing this forum: Google [Bot] and 13 guests