Page 1 of 1

how to input custom URL

PostPosted: Fri Oct 19, 2012 6:31 pm
by the-alchemist
I think I might be an idiot, but I can't for the life of me find out how to input a custom URL in the New Connection form. The connection type doesn't matter, but just for the sake of completeness, I have my own Cassandra driver type.

Needless to say, that won't work (Illegal character) and I can't input the keyspace manually.

But what I really want to do is just manually input the URL.


Re: how to input custom URL

PostPosted: Fri Oct 19, 2012 10:50 pm
by Serge

From the auto-generated URL I see that you filled "Sample URL" field in driver editor with something like jdbc:cassandra://{host}:{port}/{keyspace}.
If you want to use plain JDBC url without host/port/etc fields - just leave this field blank.
If you want to use these fields (which is actually convinient) then you need valid sample URL. There is no such pattern as {keyspace} but you may use {database} instead. Actually this information is in driver editor's help page (just press F1 or click on "?" button).
Hope it will help.

BTW standard cassandra driver is not very usefull, it doesn't provide metainformation about keyspaces but only allows to execute CQL. But we are going to add our own extension for cassandra and probably mongo db in one of future versions.


Re: how to input custom URL

PostPosted: Wed Oct 24, 2012 4:01 pm
by the-alchemist

Re: how to input custom URL

PostPosted: Thu Oct 25, 2012 9:43 am
by Serge

Yes, probably we need to improve driver editor dialog to make it less confusing (specifically in Sampel URL part of it). I'll think about UI cganges.

Cassandra driver is a big deal, indeed. At the moment there is no good UI tools to explore database at all. I myself need cassandra db explorer for my primary job so I'm going to make it soon. Doesn't looks like a very complex task :)
I'm going to start in November after 2.0 version will become more stable.

Concerning email notifications. Yes, it is a problem. Currently all email notifications are turned off because we use Google smtp server and it immediatelly adds any masssive sender hosts in spambot list. Dunno how to deal with it. Generally I think we need to move to another mail server...