-Xmx option

Note: please leave bug reports and feature requests on

-Xmx option

Postby b0c1 » Tue Mar 13, 2012 8:06 pm

Hi!

How can I increase the memory? I want to load a 100M+ sql script (dump), but I get out of memory error.
I tried dbeaver -vmargs -Xmx768m but it's not work...
b0c1
 
Posts: 22
Joined: Tue Mar 01, 2011 1:13 pm

Re: -Xmx option

Postby Serge » Wed Mar 14, 2012 5:51 pm

Hi!

1. It is really not a good idea to execute huge scripts in SQL editor. 100M scipt will eat a few gigabytes of memory (due to syntax highlighting and other intellectual text editor features).
To execute huge scripts (e.g. database dumps) you may use "Execute script" tool (you may find it in Tools submenu of database context menu or "Database" main menu). "Execute scipt" tool is available only for MySQL. Oracle has similar tool "Execute in SQL*Plus". For other databases you should use some native client features.

2. Actually -vmargs works fine. E.g. you may start DBeaver with parameters "-vmargs -Xms500m" - and you will see that initial heap size is about 500Mb. I think 768Mb just not enough for your script (see p.1) so it doesn't make sense to increase maximum memory size for such big scripts.

Thanks!
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: -Xmx option

Postby b0c1 » Wed Mar 14, 2012 5:56 pm

Thnx...
b0c1
 
Posts: 22
Joined: Tue Mar 01, 2011 1:13 pm


Return to Support



Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot] and 9 guests