DBeaver not starting on Sabayon x64

Note: please leave bug reports and feature requests on

DBeaver not starting on Sabayon x64

Postby svakak » Mon Nov 21, 2011 10:11 am

svakak
 
Posts: 5
Joined: Mon Nov 21, 2011 10:06 am

Re: DBeaver not starting on Sabayon x64

Postby svakak » Mon Nov 21, 2011 2:59 pm

If it's of any help I can run Eclipse and other Java apps on my computer. That tells me that Java is installed correctly.
svakak
 
Posts: 5
Joined: Mon Nov 21, 2011 10:06 am

Re: DBeaver not starting on Sabayon x64

Postby Serge » Mon Nov 21, 2011 7:36 pm

Hi!

What DBeaver version have you installed? You can't use deb package because it contains 32 bit version (it seems to be our mistake, in next version will make two different deb packages). Currently you should download zip archive for 64bit environment.
32 bit DBeaver version won't run if you have 64 bit java version (it is not clear what Java do you have, but most likely it is 64 bit because you use 64 bit Linux).

If you intalled correct DBeaver and it still doesn't run then could you check for eclipse log - it should be located in /opt/dbeaver/configuration folder?

Thanks!
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: DBeaver not starting on Sabayon x64

Postby svakak » Mon Nov 21, 2011 8:16 pm

Hi, thanks for your replay.

I have tried both 32 and 64-bit DBeaver with same results, log does appears to be in configuration directory. Is there some switch to tell dbeaver to be more verbose? Did I tell that splash screen appears on the screen, and dissapears after two secconds?

I have installed Kubuntu in VM and DBeaver works there like a charm. This must be some Sabayon/Gentoo specific issue. Do you have some other pointers where I should look for solution? It would be shame to miss on great tool like DBeaver. Finally there is decent database manager for Linux.

Josip
svakak
 
Posts: 5
Joined: Mon Nov 21, 2011 10:06 am

Re: DBeaver not starting on Sabayon x64

Postby Serge » Mon Nov 21, 2011 8:40 pm

Hmm.
So, if you see any log files in "/opt/dbeaver/configuration" folder - could you attach them (or send me to serge@jkiss.org)? Also log file could be located in the same older where dbeaver was installed or in "configuration" subfolder. Any files with .log extension.
I'm afraid I can't figure out the problem without additional information :( If there are no any log files then the only thing we can do is to test on Sabayon on local VM, but it will take quite much time..

Thanks for you report, we'll try to figure out the reason in any case.
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: DBeaver not starting on Sabayon x64

Postby svakak » Tue Nov 22, 2011 5:21 pm

Hi, I have found a solution, more like a workaround;

* Start Ubuntu 64bit from CD
* Install Java
* Run dbeaver
* copy $HOME/.dbeaver from Ubuntu -> Sabayon
* reboot to Sabayon and start dbeaver

Now everything works.
svakak
 
Posts: 5
Joined: Mon Nov 21, 2011 10:06 am

Re: DBeaver not starting on Sabayon x64

Postby Serge » Tue Nov 22, 2011 8:11 pm

Wow, that was a tricky workaround :)
But it gives an understanding of the proble nature.

Obviously problem was in configuration saved by previous DBeaver start, may be even by previous version of DBeaver. I never experienced such problem before, but it is possible.
Probably simple removal of .dbeaver folder (or, better, .dbeaver/.metadata folder) could help in this situation. It will remove all saved projects and settings but at least it will work.. Moreover it is possible to restore projects by copying their content from original (broken) .dbeaver folder.

Also I'll make more investogations of this issue to prevent it in future.

Thanks a lot for this information!
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: DBeaver not starting on Sabayon x64

Postby svakak » Tue Nov 22, 2011 10:04 pm

Attachments
snapshot1.png
snapshot1.png (25.93 KiB) Viewed 29092 times
svakak
 
Posts: 5
Joined: Mon Nov 21, 2011 10:06 am

Re: DBeaver not starting on Sabayon x64

Postby Serge » Thu Nov 24, 2011 6:53 am

Could you send log with errors? It will take me a chance to fix this problem in nearest version.
Logs should be located in .dbeaver/.metadata folder. debug.log usually doesn't contain usefull info but it also can help.

Thanks for your investigations!
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb


Return to Support



Who is online

Users browsing this forum: No registered users and 4 guests