Page 1 of 1

Field editing

PostPosted: Tue Sep 27, 2011 11:07 am
by arm8
Hi all,
congratulations for this a great tool. So far I'm enjoing it.

Still, I have a problem. When I edit a table, I'm unable to edit the Data.
The result shows table cells with the description, [BigDecimal], [TIMESTAMP]
When I execute a SQL select, the results in the Data Grid appear correctly and I can edit them.
I'm using DBEaver 1.4.0 and Oracle 11g as the database

Am i doing something wrong or is this a bug?

Regards

Re: Field editing

PostPosted: Tue Sep 27, 2011 11:20 am
by Support
Thanks for report!

Could you say what exactly data types have these "bad" columns?
This is obviously a bug in the Oracle plugin. It will be fixed in following hotfix version. Which will be released, probably, at the begining of October.

Re: Field editing

PostPosted: Tue Sep 27, 2011 12:06 pm
by arm8
The exact types are:
[BigDecimal] -> NUMBER(10,0)
[TIMESTAMP] -> TIMESTAMP (6)

VARCHAR2 columns are displayed correctly but are also uneditable.

As a side note, when I expand the columns node of a table in Database Navigator tab, the icon of all columns is a question mark.

Re: Field editing

PostPosted: Thu Oct 06, 2011 6:11 pm
by arm8
Hi,
I just downloaded 1.4.1 version, and the data in the table Data tab now is shown as expected. Nice :D

However, I can't edit the data. (Any kind of data)

Regards

Re: Field editing

PostPosted: Thu Oct 06, 2011 6:42 pm
by Serge
Hmm.
Generally you can edit table if it has at least one unique key (e.g. PK) or unique index. Are you sure your table has one?

Actually it is not a DBeaver limitation but term of relational theory - row has to have some unique identifier, otherwise it can't be modified in "consistent" way. But we have plans to implement "logical keys" feature - while table doesn't have physical keys user may define some columns (all table columns in general case) as key to be able to manipulate data.

I can't say when exactly we will add this feature, we need more votes for it as it is not so simple ;)

Re: Field editing

PostPosted: Thu Oct 06, 2011 8:22 pm
by Serge
I have another idea about this problem - in case if your table has unique key and still not editable.
DBeaver uses different system tables to determine column datatype and sometimes these tables contain unexpected values. We try to handle such situation but sometimes it still doesn't work..
Do you use Oracle 11g? Is it a plain new database or upgrade from some previous Oracle version (e.g. 10g)?

In any case - I've just made new EA version - it is available here: http://dbeaver.jkiss.org/files/ea/ - could you check it?

And thanks a lot for you reports and your patience :)

Re: Field editing

PostPosted: Fri Oct 07, 2011 10:17 am
by arm8
Good news, it works. :D
Using the v1.4.2 the edit dialog pops up and I can change the values.

Reporting it is the least I can do, in return for your work.

Keep up the good work.

Re: Field editing

PostPosted: Mon Oct 17, 2011 1:53 pm
by guimoreno
Hi!

I connect to a sql server 2008 database, when i edit a table, the data is editable, but in a query, isn't, even in 1.4.2.
Any help? Tks.

Re: Field editing

PostPosted: Mon Oct 17, 2011 8:07 pm
by Support
Most database drivers doesn't support custom query edit because they doesn't provide neccessary metadata for queries (source table/column names).
Generally SQL query result is not editable (it may return calculated/aggregated values, result of joins with additional tables without these tables PK values and so on). Query result may be edited only if it is based on some physical table columns and contains some unique key from this table.

Currently the only tested database driver which returns information about source tables is MySQL. In all other databases you can edit tableso only directly.

So this feature is not available for MS SQL and won't be available in nearest future.