Content Assist for MySQL

Note: please leave bug reports and feature requests on

Content Assist for MySQL

Postby bits4beats » Mon Sep 26, 2011 8:42 pm

bits4beats
 
Posts: 9
Joined: Wed Mar 30, 2011 6:44 pm

Re: Content Assist for MySQL

Postby Support » Tue Sep 27, 2011 8:15 am

This feature (content assist) supported in all versions of DBeaver and for all types of databases.
Just tested exactly this query (select * from users u u.) and it works fine.

Do you see table columns after you enter "u." and wait for a second?
May be the problem is in broken shortcut.
If it doesn't work anyway, could you check error log (menu Window -> Error Log) for errors after you press Ctrl+Space?
Support
 
Posts: 49
Joined: Thu Mar 17, 2011 10:11 am

Re: Content Assist for MySQL

Postby bits4beats » Tue Sep 27, 2011 9:07 am

I wait 1 second , the waiting cursor appears but nothing happens. Sometimes a window opens and closes immediately.

The same operation is instead successfully for asking the list of tables for a schema.
The window log is empty and the debug.log file prints nothing during this operation.

Maybe should I remove my preferences? If I roll back to 1.2 then this content assist works.
bits4beats
 
Posts: 9
Joined: Wed Mar 30, 2011 6:44 pm

Re: Content Assist for MySQL

Postby Support » Tue Sep 27, 2011 9:51 am

Hmm. Pretty strange behaviour. We will try to reproduce this issue and check the difference between 1.2 and 1.3.

Could you say what OS do you use and what version of MySQL?

Thank you for this report, we'll fix it as we'lll be able to reproduce it.
Support
 
Posts: 49
Joined: Thu Mar 17, 2011 10:11 am

Re: Content Assist for MySQL

Postby bits4beats » Tue Sep 27, 2011 10:02 am

I'm using Linux, Ubuntu 8.04 32bit .
The MySQL database version is 5.0.51a-3ubuntu5.1-log (5.0.51).

Thank you for your support.
Dbeaver is a very killer database application, thanks for your work!

P.S: I'm ready to investigate a bit further, if needed.
bits4beats
 
Posts: 9
Joined: Wed Mar 30, 2011 6:44 pm

Re: Content Assist for MySQL

Postby bits4beats » Tue Sep 27, 2011 10:10 am

Just 2 screens to show the content assist window in opening tables list

screen_full_2011_09_27-12_00_04.png
screen_full_2011_09_27-12_00_04.png (136.38 KiB) Viewed 21726 times


and the "nothing happens" screen during columns list search

screen_full_2011_09_27-12_00_41.png
screen_full_2011_09_27-12_00_41.png (110.18 KiB) Viewed 21726 times


Bye
bits4beats
 
Posts: 9
Joined: Wed Mar 30, 2011 6:44 pm

Re: Content Assist for MySQL

Postby Support » Tue Sep 27, 2011 11:22 am

Thank you for detailed report, I believe we have enough information.
We'll include fix of this bug in the nearest hotfix version (beginning of October)
Support
 
Posts: 49
Joined: Thu Mar 17, 2011 10:11 am

Re: Content Assist for MySQL

Postby bits4beats » Tue Sep 27, 2011 1:31 pm

I'll be waiting for DBeaver updates.

Have a nice work!
bits4beats
 
Posts: 9
Joined: Wed Mar 30, 2011 6:44 pm

Re: Content Assist for MySQL

Postby Serge » Tue Oct 04, 2011 8:45 pm

Autocomplete fixed. Version 1.4.1 is ready for download.
This problem occured only with fully qualified table names (with explicit schema/database name).
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: Content Assist for MySQL

Postby bits4beats » Tue Oct 04, 2011 10:25 pm

Ah ok, glad to know you found the misterious bug.
I'm downloading and testing the new version.

ROb
bits4beats
 
Posts: 9
Joined: Wed Mar 30, 2011 6:44 pm

Next

Return to Support



Who is online

Users browsing this forum: No registered users and 6 guests