bug in the list procedure names (tree)

Note: please leave bug reports and feature requests on

bug in the list procedure names (tree)

Postby kezcerad » Wed Dec 09, 2015 1:24 pm

Dear All,
I find bug in the list of procedures.
I see problem in PostgreSQL and MSSQL.

In PostgreSQL I see every procedure twice, second procedure with the same name.
In MSSQL I see every procedure twice, second procedure with with suffix ";0" or ";1").
Attachments
dbeaver_postgresql.jpg
screen POSTGRESQL (bug)
dbeaver_postgresql.jpg (19.08 KiB) Viewed 17870 times
dbeaver_mssql.jpg
screen MSSQL (bug)
dbeaver_mssql.jpg (18.53 KiB) Viewed 17870 times
kezcerad
 
Posts: 4
Joined: Wed Dec 09, 2015 1:07 pm

Re: bug in the list procedure names (tree)

Postby kezcerad » Wed Dec 09, 2015 1:26 pm

problem in version 3.5.6
kezcerad
 
Posts: 4
Joined: Wed Dec 09, 2015 1:07 pm

Re: bug in the list procedure names (tree)

Postby Serge » Wed Dec 09, 2015 2:45 pm

It is a bug in the recent versions. Will be fixed in 3.5.7.
Thanks for report!
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: bug in the list procedure names (tree)

Postby kezcerad » Mon Dec 21, 2015 10:11 am

Hello,
I installed version 3.5.7 and I see correct tree in PostgreSQL but procedures i MSSQL has still problem.
Attachments
Zaznaczenie_004.jpg
Zaznaczenie_004.jpg (14.64 KiB) Viewed 17760 times
kezcerad
 
Posts: 4
Joined: Wed Dec 09, 2015 1:07 pm

Re: bug in the list procedure names (tree)

Postby Serge » Mon Dec 21, 2015 10:45 am

Can't reproduce that.

What driver/server do you use?
Maybe some SQL snippet which will let to reproduce?.

BR
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: bug in the list procedure names (tree)

Postby kezcerad » Mon Dec 21, 2015 11:42 am

driver: MS SQL Server / Microsoft Driver
kezcerad
 
Posts: 4
Joined: Wed Dec 09, 2015 1:07 pm

Re: bug in the list procedure names (tree)

Postby Serge » Mon Dec 21, 2015 12:29 pm

Seems to be an SQL Server-specific (MS driver specific actually) issue. jTDS driver works ok.
Will be fixed in the next version, thanks for report.
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb


Return to Support



Who is online

Users browsing this forum: Google [Bot] and 6 guests

cron