Won't list collections for MongoDB

Note: please leave bug reports and feature requests on

Won't list collections for MongoDB

Postby joao-t-pio » Fri Nov 27, 2015 12:17 pm

Hello all.

I have two remote servers running MongoDB databases and I've been trying to set up DBeaver to work with them, but i come across a weird problem.
For the first server I connect without a problem, see the available databases and also the collections inside each one.
For the second server, I connect without a problem, see the available databases but cannot see the collections. It's like they don't exist for DBeaver.

Relevant Info:
- Both remote servers are accessed directly. No tunnels or any funny business.
- The problematic server has collections and data in them, since i connect through ssh, enter mongo, go to the database i want and list the contents of collections.
- In the connection configuration screen the "Test Connection ..." function for the problematic server answers with success.
- I have no mongo authentication configured in both remote servers. When using ssh and entering the command line mongo, I don't need to provide credentials. I also have "NONE" in the credentials mechanism.
- Using DBeaver version 3.3.0 on Windows
- Both remote servers are linux with the same distro.
- The working remote server has mongodb 2.4.8 and Java Driver 2.12.2
- The problematic remote server has mongodb 2.4.12 and Java Driver 2.12.2

I was trying to find out which version of mongodb DBeaver supports, but all i could find was that for version 3.4.5 of DBeaver, MongoDB 3.x support was added.
joao-t-pio
 
Posts: 4
Joined: Fri Nov 27, 2015 12:03 pm

Re: Won't list collections for MongoDB

Postby joao-t-pio » Fri Nov 27, 2015 3:06 pm

UPDATE: I've upgraded DBeaver to version 3.5.4. Still same issue.
joao-t-pio
 
Posts: 4
Joined: Fri Nov 27, 2015 12:03 pm

Re: Won't list collections for MongoDB

Postby Serge » Tue Dec 01, 2015 10:26 am

Hello,

I have no clues so far.
Are there any errors/warnings in the Error Log view?
You can clean it up and then try to connect and then expand collection list.
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: Won't list collections for MongoDB

Postby joao-t-pio » Tue Dec 01, 2015 11:57 am

No messages whatsoever. I also can't see any collections in any of the other databases.

Is the erro log view the deepest level of logging?
joao-t-pio
 
Posts: 4
Joined: Fri Nov 27, 2015 12:03 pm

Re: Won't list collections for MongoDB

Postby Serge » Tue Dec 01, 2015 12:09 pm

You can also check debug log (%HOMEPATH%\.dbeaver\.metadata\dbeaver-debug.log).
Also a screenshot could be helpful.

Regards
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: Won't list collections for MongoDB

Postby joao-t-pio » Tue Dec 01, 2015 3:47 pm

This is the log for the process of opening both connections, where 172.18.174.34 is the problematic server and 10.112.83.248 is the working one:

2015-12-03 15:36:12.794 - DBeaver Enterprise 3.5.4 is starting
2015-12-03 15:36:12.795 - Install path: 'file:/C:/Program Files/DBeaver/'
2015-12-03 15:36:12.796 - Instance path: 'file:/C:/Users/Joao Pio/.dbeaver/'
2015-12-03 15:36:15.260 - Initializing DBeaver Enterprise 3.5.4
2015-12-03 15:36:15.261 - Host plugin: com.jkiss.dbeaver.ent.application 3.5.4
2015-12-03 15:36:15.261 - Initialize Core...
2015-12-03 15:36:15.593 - Opening QMDB connection...
2015-12-03 15:36:15.930 - QMDB started
2015-12-03 15:36:15.931 - Core initialized (670ms)
2015-12-03 15:36:17.286 - MONGO INFO: Cluster created with settings {hosts=[172.18.174.34:27017], mode=SINGLE, requiredClusterType=UNKNOWN, serverSelectionTimeout='30000 ms', maxWaitQueueSize=500, description='DBeaver Enterprise 3.5.4'}
2015-12-03 15:36:17.368 - MONGO INFO: No server chosen by ReadPreferenceServerSelector{readPreference=primary} from cluster description ClusterDescription{type=UNKNOWN, connectionMode=SINGLE, all=[ServerDescription{address=172.18.174.34:27017, type=UNKNOWN, state=CONNECTING}]}. Waiting for 30000 ms before timing out
2015-12-03 15:36:18.850 - MONGO INFO: Opened connection [connectionId{localValue:1, serverValue:523115}] to 172.18.174.34:27017
2015-12-03 15:36:19.219 - MONGO INFO: Monitor thread successfully connected to server with description ServerDescription{address=172.18.174.34:27017, type=STANDALONE, state=CONNECTED, ok=true, version=ServerVersion{versionList=[2, 4, 12]}, minWireVersion=0, maxWireVersion=0, electionId=null, maxDocumentSize=16777216, roundTripTimeNanos=362620727}
2015-12-03 15:36:20.679 - MONGO INFO: Opened connection [connectionId{localValue:2, serverValue:523116}] to 172.18.174.34:27017
2015-12-03 15:36:34.819 - MONGO INFO: Cluster created with settings {hosts=[10.112.83.248:27017], mode=SINGLE, requiredClusterType=UNKNOWN, serverSelectionTimeout='30000 ms', maxWaitQueueSize=500, description='DBeaver Enterprise 3.5.4'}
2015-12-03 15:36:34.822 - MONGO INFO: No server chosen by ReadPreferenceServerSelector{readPreference=primary} from cluster description ClusterDescription{type=UNKNOWN, connectionMode=SINGLE, all=[ServerDescription{address=10.112.83.248:27017, type=UNKNOWN, state=CONNECTING}]}. Waiting for 30000 ms before timing out
2015-12-03 15:36:34.938 - MONGO INFO: Opened connection [connectionId{localValue:3, serverValue:2158}] to 10.112.83.248:27017
2015-12-03 15:36:34.964 - MONGO INFO: Monitor thread successfully connected to server with description ServerDescription{address=10.112.83.248:27017, type=STANDALONE, state=CONNECTED, ok=true, version=ServerVersion{versionList=[2, 4, 8]}, minWireVersion=0, maxWireVersion=0, electionId=null, maxDocumentSize=16777216, roundTripTimeNanos=23205288}
2015-12-03 15:36:35.063 - MONGO INFO: Opened connection [connectionId{localValue:4, serverValue:2159}] to 10.112.83.248:27017

This is a screenshot of what both databases show me in the UI:
mongo.JPG
mongo.JPG (106.32 KiB) Viewed 14841 times
joao-t-pio
 
Posts: 4
Joined: Fri Nov 27, 2015 12:03 pm


Return to Support



Who is online

Users browsing this forum: No registered users and 23 guests