Upgrade to 3.5.2 version

Note: please leave bug reports and feature requests on

Upgrade to 3.5.2 version

Postby ggcasalone » Fri Oct 23, 2015 1:53 pm

Hi all, I am trying to install the latest version on my Mac but after I had unzipped the .tar.gz and executed Dbeaver I am having the following error:

!SESSION 2015-10-23 15:51:49.358 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_65
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=it_IT
Framework arguments: -keyring /Users/casalone/.eclipse_keyring -showlocation
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -keyring /Users/casalone/.eclipse_keyring -showlocation

!ENTRY org.eclipse.compare.core 4 0 2015-10-23 15:51:50.266
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.compare.core [14]
Unresolved requirement: Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.1.v20150903-1804"; singleton:="true"
org.eclipse.core.runtime [25]
Unresolved requirement: Require-Bundle: org.eclipse.core.jobs; bundle-version="[3.2.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.core.jobs; bundle-version="3.7.0.v20150330-2103"; singleton:="true"
org.eclipse.core.jobs [23]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)


and many others.

Could you help me?

Many thanks

Giovanni
ggcasalone
 
Posts: 1
Joined: Fri Oct 23, 2015 1:49 pm

Re: Upgrade to 3.5.2 version

Postby Serge » Fri Oct 23, 2015 3:02 pm

Since version 3.5 DBeaver requires Java 1.7+.
Just upgrade Java on your Mac.
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb


Return to Support



Who is online

Users browsing this forum: Google [Bot] and 31 guests