Connection problem on v3.5.1

Note: please leave bug reports and feature requests on

Connection problem on v3.5.1

Postby sdrzm » Tue Oct 13, 2015 7:24 am

My previous version of dbeaver was working correctly until I has updated it to v3.5.1. After update it gives error below:


DBCConnectException: Can't create driver instance
DBException: Can't load driver class 'oracle.jdbc.OracleDriver'
java.lang.ClassNotFoundException: ClassNotFoundException: oracle.jdbc.OracleDriver

Image

Could you please help me? I can work with TOAD currently, so there should not be a driver problem.
sdrzm
 
Posts: 10
Joined: Wed Jan 07, 2015 9:58 am

Re: Connection problem on v3.5.1

Postby Serge » Tue Oct 13, 2015 9:06 am

Since version 3.5 DBeaver no longer provides prepackaged Oracle and DB2 JDBC drivers.
Mostly because these drivers are restricted for redistribution (by vendors).
You need to manually download them from Oracle/DB2 web site and then add downloaded jars in the driver editor.

All you need is ojdbc6.jar file.
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: Connection problem on v3.5.1

Postby sdrzm » Tue Oct 13, 2015 9:45 am

Thanks for the answer.

I added jdbc.jar

Image

But now I have another error.

Image

Could you help me please?
sdrzm
 
Posts: 10
Joined: Wed Jan 07, 2015 9:58 am

Re: Connection problem on v3.5.1

Postby Serge » Tue Oct 13, 2015 11:54 am

ORA-12516 is a tricky error. It is server-side error, it means that server is out of free handles to open a new connection. Or you have some misconfiguration in connection parameters.
Make sure that connection properties are the same as they were before.
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: Connection problem on v3.5.1

Postby sdrzm » Tue Oct 13, 2015 11:58 am

Hi Serge,

Thanks for your help. I configured manually and it is working now...
sdrzm
 
Posts: 10
Joined: Wed Jan 07, 2015 9:58 am


Return to Support



Who is online

Users browsing this forum: Google [Bot] and 11 guests