3.5.1 not open

Note: please leave bug reports and feature requests on

3.5.1 not open

Postby KiPSOFT » Mon Oct 05, 2015 10:26 am

Hi;

i have eclipse error in 3.5.1. this software not open. operating software ubuntu 15.01 error log;

!SESSION 2015-10-05 13:22:51.604 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_45-internal
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=tr_TR
Framework arguments: -nl -en
Command-line arguments: -os linux -ws gtk -arch x86_64 -nl -en

!ENTRY org.eclipse.osgi 4 0 2015-10-05 13:22:56.064
!MESSAGE Application error
!STACK 1
java.lang.NullPointerException: null values not allowed
at org.eclipse.core.internal.registry.ReferenceMap.put(ReferenceMap.java:351)
at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.getBundle(RegistryStrategyOSGI.java:151)
at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:166)
at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:905)
at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:55)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:191)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:669)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:608)
at org.eclipse.equinox.launcher.Main.run(Main.java:1515)
at org.eclipse.equinox.launcher.Main.main(Main.java:1488)

thanks.
KiPSOFT
 
Posts: 16
Joined: Tue Jul 28, 2015 12:04 am

Re: 3.5.1 not open

Postby rbruyn » Mon Oct 05, 2015 10:43 am

Same here. Tried downgrading to 3.5.0 but made no difference.
rbruyn
 
Posts: 2
Joined: Mon Oct 05, 2015 10:37 am

Re: 3.5.1 not open

Postby Serge » Mon Oct 05, 2015 10:49 am

This is a know Eclipse issue (https://bugs.eclipse.org/bugs/show_bug.cgi?id=461781). It is not related to a particular DBeaver version.
Workaround - delete everything in directory "configuration" except file "config.ini", "org.eclipse.equinox.simpleconfigurator" and "org.eclipse.update".
BTW it'd be a good idea to completely remove previous DBeaver version before installing new one.
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: 3.5.1 not open

Postby Serge » Mon Oct 05, 2015 10:56 am

Better solution: try to run dbeaver with "-clean" command line option.
Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Re: 3.5.1 not open

Postby KiPSOFT » Mon Oct 05, 2015 11:20 am

Thanks serge.

i'm delete /usr/share/dbeaver/configuration folder and reinstall. great working.
KiPSOFT
 
Posts: 16
Joined: Tue Jul 28, 2015 12:04 am

Re: 3.5.1 not open

Postby carlosspohr » Mon Oct 05, 2015 12:58 pm

carlosspohr
 
Posts: 17
Joined: Mon Jan 27, 2014 11:53 am

Re: 3.5.1 not open

Postby rbruyn » Mon Oct 05, 2015 1:18 pm

the clean option worked for me to.
Tnx!
rbruyn
 
Posts: 2
Joined: Mon Oct 05, 2015 10:37 am

Re: 3.5.1 not open

Postby MetraMark » Tue Oct 06, 2015 4:57 pm

/usr/share/dbeaver/dbeaver -clean worked perfectly for me too.

Thanks!
MetraMark
 
Posts: 5
Joined: Mon Sep 28, 2015 5:54 pm

Re: 3.5.1 not open

Postby stashu » Fri Oct 09, 2015 2:27 pm

Hi all -

dbeaver -clean fails silently for me. Using Linux Mint 17. I'd be glad to quickly provide more information.
stashu
 
Posts: 4
Joined: Fri Oct 09, 2015 2:23 pm

Re: 3.5.1 not open

Postby Serge » Fri Oct 09, 2015 2:49 pm

Serge
 
Posts: 1526
Joined: Sat Feb 26, 2011 8:24 pm
Location: SPb

Next

Return to Support



Who is online

Users browsing this forum: Google [Bot] and 4 guests