Page 1 of 1

Bug with limit modifier

PostPosted: Mon Aug 10, 2015 8:46 pm
by rrsolver

Re: Bug with limit modifier

PostPosted: Wed Aug 12, 2015 11:06 am
by Serge
That's quite strange. Because execution log shows exactly the same query that DBeaver tries to execute.
And I can't reproduce this issue because I don't have an access to a live Vertica server.

DBeaver uses LIMIT modifier in all SELECT statements which do not have LIMIT inside. In some cases it can lead to errors.
You can disable implicit LIMITs: turn off checkbox in Preferences->Common->Result Sets->Queries->"Use SQL to limit fetch size".

Re: Bug with limit modifier

PostPosted: Thu Aug 13, 2015 4:44 pm
by rrsolver
I've attached screenshots showing the behavior.

Is there something I'm missing / any other way for me to get more information

error.png
error.png (93.39 KiB) Viewed 19035 times

Re: Bug with limit modifier

PostPosted: Fri Apr 08, 2016 1:26 pm
by fjmorenog
I was having the same problem, updated to the version 3.6.3 and now is working OK