Oracle connection with tnsnames.ora failing

Note: please leave bug reports and feature requests on

Oracle connection with tnsnames.ora failing

Postby foo » Sat Jul 18, 2015 3:57 pm

Hey guys,

first of all, I absolutely love dbeaver. This is the best SQL client out there! Job well done I'd say.

Now, I'm also using dbeaver for work where we're using Oracle11 databases, but I can't seem to get the connection working with TNS.

OS: Windows 7 32 bit
Client Dbeaver 3.4.2
%TNS_ADMIN% is set to the directory containing tnsnames.ora

When setting up a new connection and choosing TNS, I can actually select from a list of all databases definied in the tnsnames.ora file, but testing the connection results in an error "could not resolve connect idenfitier". Strangely enough I get the same error when using pyodbc, BUT: Using sql developer I can use TNS AND connect successfully to the database.

EDIT: I just poked around in the settings of SQL developer and realised that there is a dedicated setting for the tnsnames.ora file. After clearing that up, setting up a new connection via TNS doesn't work anymore, so I'm really wondering what I'm missing since %TNS_ADMIN% is actually set.

EDIT2: Another idea I had was to try sqlplus with an identifier from tnsnames.ora file and that actually works. So, this is weird......

Anyone got an idea what I'm missing here to use TNS?

Thanks for your help guys
foo
 
Posts: 1
Joined: Sat Jul 18, 2015 3:48 pm

Return to Support



Who is online

Users browsing this forum: Google [Bot] and 15 guests